• 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Aiuto] MySql Deepin
#1
Information 
Salve a tutti ragazzi ho un problema durante l'installazione di mysql

si solito installo dando il comando sudo apt install mysql-server mysql-client e poi seguo la procedura standard
ho installato ieri deepin su un pc ma quando faccio la procedura mi ritrovo
Codice:
sudo apt-get install mysql-client mysql-server -y
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libevent-core-2.1-6 libmecab2 mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7 mysql-server-core-5.7
Pacchetti suggeriti:
  mailx tinyca
I seguenti pacchetti NUOVI saranno installati:
  libevent-core-2.1-6 libmecab2 mysql-client mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server mysql-server-5.7
  mysql-server-core-5.7
0 aggiornati, 9 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 21,4 MB di archivi.
Dopo quest'operazione, verranno occupati 162 MB di spazio su disco.
Scaricamento di:1 http://packages.deepin.com/deepin panda/main amd64 mysql-common all 5.8+1.0.4 [7.276 B]
Scaricamento di:2 http://packages.deepin.com/deepin panda/main amd64 mysql-client-core-5.7 amd64 5.7.21-1 [7.092 kB]
Scaricamento di:3 http://packages.deepin.com/deepin panda/main amd64 mysql-client-5.7 amd64 5.7.21-1 [2.427 kB]                       
Scaricamento di:4 http://packages.deepin.com/deepin panda/main amd64 mysql-server-core-5.7 amd64 5.7.21-1 [7.874 kB]                  
Scaricamento di:5 http://packages.deepin.com/deepin panda/main amd64 libevent-core-2.1-6 amd64 2.1.8-stable-4 [129 kB]                
Scaricamento di:6 http://packages.deepin.com/deepin panda/main amd64 libmecab2 amd64 0.996-6 [258 kB]                                 
Scaricamento di:7 http://packages.deepin.com/deepin panda/main amd64 mysql-server-5.7 amd64 5.7.21-1 [3.314 kB]                       
Scaricamento di:8 http://packages.deepin.com/deepin panda/main amd64 mysql-client all 5.7.21-1 [137 kB]                               
Scaricamento di:9 http://packages.deepin.com/deepin panda/main amd64 mysql-server all 5.7.21-1 [137 kB]                               
Recuperati 21,4 MB in 1min 28s (242 kB/s)                                                                                             
Preconfigurazione dei pacchetti in corso
Selezionato il pacchetto mysql-common non precedentemente selezionato.
(Lettura del database... 209398 file e directory attualmente installati.)
Preparativi per estrarre .../0-mysql-common_5.8+1.0.4_all.deb...
Estrazione di mysql-common (5.8+1.0.4)...
Selezionato il pacchetto mysql-client-core-5.7 non precedentemente selezionato.
Preparativi per estrarre .../1-mysql-client-core-5.7_5.7.21-1_amd64.deb...
Estrazione di mysql-client-core-5.7 (5.7.21-1)...
Selezionato il pacchetto mysql-client-5.7 non precedentemente selezionato.
Preparativi per estrarre .../2-mysql-client-5.7_5.7.21-1_amd64.deb...
Estrazione di mysql-client-5.7 (5.7.21-1)...
Selezionato il pacchetto mysql-server-core-5.7 non precedentemente selezionato.
Preparativi per estrarre .../3-mysql-server-core-5.7_5.7.21-1_amd64.deb...
Estrazione di mysql-server-core-5.7 (5.7.21-1)...
Selezionato il pacchetto libevent-core-2.1-6:amd64 non precedentemente selezionato.
Preparativi per estrarre .../4-libevent-core-2.1-6_2.1.8-stable-4_amd64.deb...
Estrazione di libevent-core-2.1-6:amd64 (2.1.8-stable-4)...
Selezionato il pacchetto libmecab2:amd64 non precedentemente selezionato.
Preparativi per estrarre .../5-libmecab2_0.996-6_amd64.deb...
Estrazione di libmecab2:amd64 (0.996-6)...
Configurazione di mysql-common (5.8+1.0.4)...
update-alternatives: viene usato /etc/mysql/my.cnf.fallback per fornire /etc/mysql/my.cnf (my.cnf) in modalità automatica
Selezionato il pacchetto mysql-server-5.7 non precedentemente selezionato.
(Lettura del database... 209564 file e directory attualmente installati.)
Preparativi per estrarre .../mysql-server-5.7_5.7.21-1_amd64.deb...
Downgrade from (at least) 10.1 to 5.7 is not possible.
Packaging maintenance of MySQL will stop and the daemon disabled to prevent damage to your system.
For help, see /etc/mysql/FROZEN
Estrazione di mysql-server-5.7 (5.7.21-1)...
Selezionato il pacchetto mysql-client non precedentemente selezionato.
Preparativi per estrarre .../mysql-client_5.7.21-1_all.deb...
Estrazione di mysql-client (5.7.21-1)...
Selezionato il pacchetto mysql-server non precedentemente selezionato.
Preparativi per estrarre .../mysql-server_5.7.21-1_all.deb...
Estrazione di mysql-server (5.7.21-1)...
Configurazione di libevent-core-2.1-6:amd64 (2.1.8-stable-4)...
Configurazione di mysql-server-core-5.7 (5.7.21-1)...
Configurazione di libmecab2:amd64 (0.996-6)...
Elaborazione dei trigger per libc-bin (2.27-3)...
Elaborazione dei trigger per systemd (238-5)...
Elaborazione dei trigger per man-db (2.8.3-2)...
Configurazione di mysql-client-core-5.7 (5.7.21-1)...
Configurazione di mysql-client-5.7 (5.7.21-1)...
Configurazione di mysql-client (5.7.21-1)...
Configurazione di mysql-server-5.7 (5.7.21-1)...
Installazione della nuova versione del file di configurazione /etc/apparmor.d/usr.sbin.mysqld...
Installazione della nuova versione del file di configurazione /etc/init.d/mysql...
Installazione della nuova versione del file di configurazione /etc/logrotate.d/mysql-server...
Installazione della nuova versione del file di configurazione /etc/mysql/debian-start...
Packaging maintenance of MySQL will stop and the daemon disabled to prevent damage to your system.
For help, see /etc/mysql/FROZEN
Configurazione di mysql-server (5.7.21-1)...
Elaborazione dei trigger per systemd (238-5)...
[email protected]:~$ mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
[email protected]:~$ 
Non riesco a capire come risolvere avete consigli ?
  Cita messaggio
#2
Ciao, un consiglio, installa mariadb e non mysql, è perfettamente compatibile
apt-get remove mysql-server mysql-client
apt autoremove
apt-get install mariadb-server mariadb-client

e vedrai che tutto funziona
Ah ricordati di dare
mysql_secure_installation
per settare la password dell'utente [email protected]

Ciao
  Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)